Problem with engine || Strange sound when clutch is pressed

Got a question about your Hero engine? Get it answered here!

Problem with engine || Strange sound when clutch is pressed

Postby aadbhut » Sat Jun 21, 2014 11:17 pm

HI,

I have some problem will my bike (XTREME) which mechanics are not able to diagnose properly.

My bike runs fine when I'm driving it below 40. At top speed like 60 -90, My bike is also running smoothly. but when I press the clutch for 3-4 seconds. then strange (khat khat ) sound comes from my engine and after releasing clutch the sound goes any.

Initially mechanic told me that chain is loss but after replacing the chain pocket, the problem still persisted

Now mechanic is telling that valve might be bent and he will open the engine... Please help

Thanks for your help
aadbhut
 
Posts: 1
Joined: Sat Jun 21, 2014 11:10 pm

Re: Problem with engine || Strange sound when clutch is pres

Postby tejaskothari29 » Sat Jan 17, 2015 12:28 pm

If you are having a persistent problem with your bike, it is always important that you take it to an expert mechanic. The bike was running smoothly, but when you’re pressing the clutch, you are getting strange sound. It may be due to the engine problem. However, even after replacing the chain pocket, if you’re facing the problem, you should take it to an expert. There are chances that there may be some sort of loose material in the bike’s chain region. Get it fixed urgently or else you may find the bike stalling in the middle of the road.
tejaskothari29
 
Posts: 13
Joined: Sat Jan 17, 2015 9:51 am


Return to Engine Care